What’s Vulnerable › Vulnerabilities

CVE-2026-1092: Improper Validation of Specified Quantity in Input in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.10 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an unauthenticated user to cause denial of service due to improper input validation of JSON payloads.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.3, 18.8.9, 18.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-1092 or the next vulnerability affects your stack