What’s Vulnerable › Vulnerabilities
CVE-2026-109237: Crawl4AI 0.9.0 before 0.9.4 Untrusted Config Gate Bypass Leaks Environment Variables
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-502
Description
Crawl4AI from 0.9.0 before 0.9.4 contains an untrusted-config gate bypass that allows non-admin API clients to construct forbidden config objects by wrapping them in dict-type wrappers. Attackers can send a laundered LLMConfig with api_token set to an env reference via /config/dump to read SECRET_KEY and provider keys, enabling admin JWT forgery.
Affected products
- unclecode crawl4ai: from 0.9.0 before 0.9.4 — fixed in 0.9.4
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-5w5p-vcv6-mm3f
- https://www.vulncheck.com/advisories/crawl4ai-0.9.0-before-0.9.4-untrusted-config-gate-bypass-leaks-environment-variables
Get alerted when CVE-2026-109237 or the next vulnerability affects your stack