What’s Vulnerable › Vulnerabilities
CVE-2026-109238: Crawl4AI 0.7.0 before 0.9.4 SSRF via link_preview_config URL Seeder
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-918
Description
Crawl4AI 0.7.0 before 0.9.4 contains a server-side request forgery vulnerability that allows API clients to reach internal addresses by enabling link_preview_config on /crawl requests. Attackers can supply a controlled page with include_external and include_patterns set, causing AsyncUrlSeeder to fetch internal, private, and cloud-metadata links and return their parsed head data.
Affected products
- unclecode crawl4ai: from 0.7.0 before 0.9.4 — fixed in 0.9.4
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-wh5w-hmj3-vgg7
- https://www.vulncheck.com/advisories/crawl4ai-0.7.0-before-0.9.4-ssrf-via-link-preview-config-url-seeder
Get alerted when CVE-2026-109238 or the next vulnerability affects your stack