What’s Vulnerable › Vulnerabilities
CVE-2026-109239: Crawl4AI before 0.9.4 Blind SSRF via RobotsParser.can_fetch robots.txt Fetch
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-918
Description
Crawl4AI before 0.9.4 contains a blind server-side request forgery vulnerability in RobotsParser.can_fetch that lets unauthenticated attackers bypass Docker server egress controls. Attackers can enable check_robots_txt and use redirects or DNS rebinding to reach internal, loopback, or cloud-metadata addresses for service discovery.
Affected products
- unclecode crawl4ai: before 0.9.4 — fixed in 0.9.4
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-f77g-77vp-r96v
- https://www.vulncheck.com/advisories/crawl4ai-before-0.9.4-blind-ssrf-via-robotsparser-can-fetch-robots-txt-fetch
Get alerted when CVE-2026-109239 or the next vulnerability affects your stack