What’s Vulnerable › Vulnerabilities
CVE-2026-109264: ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 Stack Overflow in MVG Decoder
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-674
Description
ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 contains uncontrolled recursion in the MVG decoder that can exhaust the program stack. An attacker who controls a file name processed by ImageMagick can trigger a stack overflow that crashes the process, causing a denial of service.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-32; before 6.9.13-57 — fixed in 6.9.13-57, 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-57, 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/6ff963c14ccb5fefb4eb8654c8b0219033df2b20
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-pmqj-84pr-qc7c
- https://github.com/ImageMagick/ImageMagick6/commit/d4f06dcca7ad99d639af85bc347ad9fdfdcec8e2
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-57-and-7-x-before-7.1.2-32-stack-overflow-in-mvg-decoder
Get alerted when CVE-2026-109264 or the next vulnerability affects your stack