What’s Vulnerable › Vulnerabilities
CVE-2026-109266: ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 XML Injection via CIP Encoder
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-29
- Weakness: CWE-79
Description
ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 contains an XML injection vulnerability in the CIP encoder, which does not properly escape input-derived data when writing Cisco IP Phone XML output. Attackers can supply a crafted file that, when converted to CIP format, injects arbitrary markup into the generated XML.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-32 — fixed in 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/45bb7328b36c163234f5ccb7f1d494b7c4c8c775
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-3429-f84m-8qhw
- https://github.com/ImageMagick/ImageMagick6/commit/30499e67801ee8a0e70817d28b861b8616d72555
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-57-and-7-x-before-7.1.2-32-code-injection-via-cip-encoder
Get alerted when CVE-2026-109266 or the next vulnerability affects your stack