What’s Vulnerable › Vulnerabilities
CVE-2026-109272: ImageMagick 7.1.1-31 before 7.1.2-32 Null Pointer Dereference in PostScript Decoder
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-476
Description
ImageMagick 7.1.1-31 before 7.1.2-32 contains a NULL pointer dereference in the PostScript decoder that is triggered when a policy limit is reached. Attackers can supply a crafted PostScript file for processing to crash the application, causing a denial of service.
Affected products
- ImageMagick: from 7.1.1-31 before 7.1.2-32 — fixed in 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/d98509b23a547d9ccd0a8af8650d03c5c01c3722
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-58h4-rwr6-wj72
- https://www.vulncheck.com/advisories/imagemagick-7.1.1-31-before-7.1.2-32-null-pointer-dereference-in-postscript-decoder
Get alerted when CVE-2026-109272 or the next vulnerability affects your stack