What’s Vulnerable › Vulnerabilities
CVE-2026-109277: ImageMagick before 7.1.2-32 Policy Bypass via -script Operation
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-404
Description
ImageMagick before 7.1.2-32 contains a policy bypass vulnerability in the -script operation due to missing checks on file descriptor handling. Attackers can use the -script operation to close file descriptors not opened by the current operation, circumventing configured security policies.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-32 — fixed in 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/ce92ae07c2ca2c20c131eaf6da6da734c1cafce0
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-vv56-wmgw-m36w
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-32-policy-bypass-via-script-operation
Get alerted when CVE-2026-109277 or the next vulnerability affects your stack