What’s Vulnerable › Vulnerabilities
CVE-2026-109278: ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 Memory Leak in Wavelet-Denoise Operation
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-401
Description
ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 contains a memory leak in the wavelet-denoise operation, which fails to release allocated memory when a required resource cannot be acquired. Attackers can repeatedly trigger wavelet-denoise processing under resource-constrained conditions to leak memory and degrade service availability.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-32; before 6.9.13-57 — fixed in 6.9.13-57, 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-57, 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/15892fc0dc050a3693e28a214478a8d8488d648c
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-9f9w-84g3-vp2c
- https://github.com/ImageMagick/ImageMagick6/commit/0d2544e641848462e8b469c06cde69d7d77c35c6
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-57-and-7-x-before-7.1.2-32-memory-leak-in-wavelet-denoise-operation
Get alerted when CVE-2026-109278 or the next vulnerability affects your stack