What’s Vulnerable › Vulnerabilities
CVE-2026-109279: ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 Heap Buffer Overflow via Concurrent Security Policy Access
- Severity: low (CVSS 2.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-362
Description
ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 lacks proper synchronization when the security policy is accessed, so simultaneous reads and writes of the policy by multiple threads trigger a race condition that causes a heap buffer over-write. An attacker able to induce concurrent security policy access can crash the application, causing a denial of service.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-32; before 6.9.13-57 — fixed in 6.9.13-57, 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-57, 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/12db6f04e895deae4537ead10c771a244607794a
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-8x3v-wr32-qqh4
- https://github.com/ImageMagick/ImageMagick6/commit/9ddc71abea5cbe7d18164fa0f0077a105cab514f
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-57-and-7-x-before-7.1.2-32-heap-buffer-overflow-via-concurrent-security-policy-access
Get alerted when CVE-2026-109279 or the next vulnerability affects your stack