What’s Vulnerable › Vulnerabilities
CVE-2026-109281: ImageMagick 7.1.0-21 before 7.1.2-32 Heap Buffer Over-Read via -fx Option
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-18
- Weakness: CWE-125
Description
ImageMagick 7.1.0-21 before 7.1.2-32 contains a heap buffer over-read in its handling of the -fx option, where a certain -fx operation reads beyond the bounds of an allocated heap buffer in specific situations. Attackers who can get a crafted -fx expression processed can read out-of-bounds heap memory, potentially disclosing limited memory contents.
Affected products
- ImageMagick: from 7.1.0-21 before 7.1.2-32 — fixed in 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/0e82a4d0b294581186ed7b3e1dce59c858a73dba
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-cvgp-q487-j22w
- https://www.vulncheck.com/advisories/imagemagick-7.1.0-21-before-7.1.2-32-heap-buffer-over-read-via-fx-option
Get alerted when CVE-2026-109281 or the next vulnerability affects your stack