What’s Vulnerable › Vulnerabilities
CVE-2026-109297: Open WebUI 0.11.0 before 0.11.4 Denial of Service via Automation Recurrence Rules
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-23
- Weakness: CWE-400
Description
Open WebUI 0.11.0 before 0.11.4 contains a denial of service vulnerability in the automation recurrence-rule validator, whose sub-daily frequency guard parses rule text more strictly than the calendar library that executes it. Users permitted to create automations can submit whitespace-folded rules (or, in 0.11.0, lowercase frequencies or omitted RRULE prefixes) that expand per-second synchronously, blocking the shared event loop for minutes per request and on every scheduler poll.
Affected products
- open-webui: from 0.11.0 before 0.11.4 — fixed in 0.11.4
How to fix
Upgrade to a fixed version: open-webui 0.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/open-webui/open-webui/security/advisories/GHSA-whgc-vpjx-m3qh
- https://www.vulncheck.com/advisories/open-webui-0.11.0-before-0.11.4-denial-of-service-via-automation-recurrence-rules
- https://github.com/open-webui/open-webui/security/advisories/GHSA-whgc-vpjx-m3qh
Get alerted when CVE-2026-109297 or the next vulnerability affects your stack