What’s Vulnerable › Vulnerabilities
CVE-2026-109299: Open WebUI 0.9.0 before 0.11.4 Denial of Service via Recurrence Rule Validation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-23
- Weakness: CWE-400
Description
Open WebUI from 0.9.0 before 0.11.4 contains a denial of service vulnerability that allows authenticated users with automations permission to stall the instance by submitting unsatisfiable recurrence rules. Attackers can repeatedly send rules like February 30th to the automations create or update endpoints, blocking the shared event loop for seconds per request.
Affected products
- open-webui: from 0.9.0 before 0.11.4 — fixed in 0.11.4
How to fix
Upgrade to a fixed version: open-webui 0.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/open-webui/open-webui/commit/5fb869db221d9599a576e8e2eea9c3314947d25e
- https://github.com/open-webui/open-webui/security/advisories/GHSA-5w58-mwmh-vf2m
- https://www.vulncheck.com/advisories/open-webui-0.9.0-before-0.11.4-denial-of-service-via-recurrence-rule-validation
Get alerted when CVE-2026-109299 or the next vulnerability affects your stack