What’s Vulnerable › Vulnerabilities
CVE-2026-109300: Open WebUI 0.6.31 before 0.11.4 Stored XSS via Tool-Call Embeds
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-79
Description
Open WebUI from 0.6.31 before 0.11.4 contains a stored cross-site scripting vulnerability in its Markdown renderer, which treats user-authored tool-call details blocks as tool output and mounts their embeds attribute in script-enabled iframes. Authenticated users can post crafted channel messages, chat messages, or citation content that runs JavaScript in viewers' browsers, enabling in-app phishing, or session hijacking where iframeSandboxAllowSameOrigin is enabled.
Affected products
- open-webui: from 0.6.31 before 0.11.4 — fixed in 0.11.4
How to fix
Upgrade to a fixed version: open-webui 0.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/open-webui/open-webui/security/advisories/GHSA-9wj4-mcm3-ppj6
- https://www.vulncheck.com/advisories/open-webui-0.6.31-before-0.11.4-stored-xss-via-tool-call-embeds
- https://github.com/open-webui/open-webui/security/advisories/GHSA-9wj4-mcm3-ppj6
Get alerted when CVE-2026-109300 or the next vulnerability affects your stack