What’s Vulnerable › Vulnerabilities
CVE-2026-109311: vLLM before 0.29.0 Heap Overflow DoS via IAMF Audio Transcription Upload
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-18
- Weakness: CWE-20
Description
vLLM before 0.29.0 passes uploaded audio to the PyAV/FFmpeg av.open() fallback with only a file-size check, exposing FFmpeg's IAMF parser heap overflow. Authenticated remote attackers can repeatedly upload malformed IAMF containers to /v1/audio/transcriptions, corrupting the heap and crashing the API process.
Affected products
- vllm-project vllm: before 0.29.0 — fixed in 0.29.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-m52c-39rh-f3gp
- https://www.vulncheck.com/advisories/vllm-before-0.29.0-heap-overflow-dos-via-iamf-audio-transcription-upload
- https://github.com/vllm-project/vllm/security/advisories/GHSA-m52c-39rh-f3gp
Get alerted when CVE-2026-109311 or the next vulnerability affects your stack