What’s Vulnerable › Vulnerabilities
CVE-2026-109312: Grav Login Plugin 2.7.0 before 3.9.9 2FA Bypass via Profile Update Form
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-287
Description
Grav Login plugin 2.7.0 before 3.9.9 contains an authentication bypass in processUserProfile(), which checks that the session user exists but not that a pending front-end 2FA session is fully authorized. Attackers with a victim's password who can publish a page form without an access rule can invoke update_user before completing 2FA to disable twofa_enabled and take over the account.
Affected products
- getgrav grav-plugin-login: from 2.7.0 before 3.9.9 — fixed in 3.9.9
How to fix
Upgrade to a fixed version: getgrav grav-plugin-login 3.9.9. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-5rph-jqcf-2x36
- https://www.vulncheck.com/advisories/grav-login-plugin-2.7.0-before-3.9.9-2fa-bypass-via-profile-update-form
Get alerted when CVE-2026-109312 or the next vulnerability affects your stack