What’s Vulnerable › Vulnerabilities
CVE-2026-109313: Grav Login Plugin 2.7.0 before 3.9.9 2FA Bypass via Remember-Me Cookie
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-287
Description
Grav Login plugin 2.7.0 before 3.9.9 contains an authentication bypass vulnerability that allows attackers with a valid password to skip two-factor authentication through remember-me cookie restoration. Attackers can obtain a persistent remember-me cookie after the password step and restore it as a fully authorized session without completing the second factor.
Affected products
- getgrav grav-plugin-login: from 2.7.0 before 3.9.9 — fixed in 3.9.9
How to fix
Upgrade to a fixed version: getgrav grav-plugin-login 3.9.9. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-cmg5-qw8p-gxcf
- https://www.vulncheck.com/advisories/grav-login-plugin-2.7.0-before-3.9.9-2fa-bypass-via-remember-me-cookie
Get alerted when CVE-2026-109313 or the next vulnerability affects your stack