What’s Vulnerable › Vulnerabilities
CVE-2026-109314: Grav Login Plugin 1.2.0 before 3.9.9 Password Reset Token Disclosure via Reset Page
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-200
Description
Grav Login plugin 1.2.0 before 3.9.9 contains an information disclosure vulnerability that allows publishers to obtain password-reset tokens by authoring a page at the reset route. When a victim opens an emailed reset link, the publisher-controlled page rendered by Login::getPage() exposes the username and bearer token, enabling takeover of more privileged accounts.
Affected products
- getgrav grav-plugin-login: from 1.2.0 before 3.9.9 — fixed in 3.9.9
How to fix
Upgrade to a fixed version: getgrav grav-plugin-login 3.9.9. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-277m-9x28-gjq2
- https://www.vulncheck.com/advisories/grav-login-plugin-1.2.0-before-3.9.9-password-reset-token-disclosure-via-reset-page
Get alerted when CVE-2026-109314 or the next vulnerability affects your stack