What’s Vulnerable › Vulnerabilities
CVE-2026-109317: Grav API Plugin before 1.0.36 Privilege Escalation via Scalar Access Grants
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-269
Description
Grav grav-plugin-api before 1.0.36 contains a privilege escalation vulnerability that allows delegated user managers to obtain super-admin access by storing positive scalar admin or api parent grants. Attackers with api.users.write can edit account access maps or invitations so the inheriting permission resolver satisfies requireSuper checks, accessing super-only API endpoints.
Affected products
- getgrav grav-plugin-api: before 1.0.36 — fixed in 1.0.36
How to fix
Upgrade to a fixed version: getgrav grav-plugin-api 1.0.36. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-m2rq-76vx-vv4j
- https://www.vulncheck.com/advisories/grav-api-plugin-before-1.0.36-privilege-escalation-via-scalar-access-grants
Get alerted when CVE-2026-109317 or the next vulnerability affects your stack