What’s Vulnerable › Vulnerabilities
CVE-2026-109320: Grav API Plugin before 1.0.36 Disabled Account Session Access Bypass
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-613
Description
The Grav API plugin (grav-plugin-api) before 1.0.36 contains an improper session validation vulnerability that allows disabled accounts to keep API access, because SessionAuthenticator does not enforce account state. Disabled users can reuse an already authorized browser or remember-me session to call API endpoints until expiry, defeating operator revocation.
Affected products
- getgrav grav-plugin-api: before 1.0.36 — fixed in 1.0.36
How to fix
Upgrade to a fixed version: getgrav grav-plugin-api 1.0.36. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-7qfj-82q8-frw6
- https://www.vulncheck.com/advisories/grav-api-plugin-before-1.0.36-disabled-account-session-access-bypass
Get alerted when CVE-2026-109320 or the next vulnerability affects your stack