What’s Vulnerable › Vulnerabilities
CVE-2026-109321: Grav Login OAuth Plugin before 1.4.3 Predictable Local Credentials Authentication Bypass
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-18
- Weakness: CWE-1391
Description
Grav Login OAuth plugin (grav-plugin-login-oauth) before 1.4.3 provisions OAuth accounts as ordinary Grav users with a deterministic <provider>.<id> username and an unsalted MD5 hash of the provider identifier as the password, without disabling password login. Unauthenticated remote attackers who learn or guess a provider identifier can reproduce these credentials and log in, gaining administrative control of privileged accounts.
Affected products
- getgrav grav-plugin-login-oauth: from 1.0.0-beta.1 before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: getgrav grav-plugin-login-oauth 1.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-mj8v-hvf6-73gm
- https://www.vulncheck.com/advisories/grav-login-oauth-plugin-before-1.4.3-predictable-local-credentials-authentication-bypass
Get alerted when CVE-2026-109321 or the next vulnerability affects your stack