What’s Vulnerable › Vulnerabilities

CVE-2026-109322: Grav Guestbook before 0.5.2 Stored XSS via AJAX Pagination and Admin Views

Description

Grav Guestbook plugin before 0.5.2 contains a stored cross-site scripting vulnerability because its AJAX Load more and Admin Load all handlers insert stored author and message fields into the DOM as unescaped HTML via jQuery. Unauthenticated visitors can submit markup that executes in other visitors' browsers and, in versions 0.5.0 and 0.5.1, in administrator moderation sessions.

Affected products

How to fix

Upgrade to a fixed version: getgrav grav-plugin-guestbook 0.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-109322 or the next vulnerability affects your stack