What’s Vulnerable › Vulnerabilities
CVE-2026-109324: Grav before 2.1.7 Memory Exhaustion via Oversized Image Transforms
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-409
Description
Grav before 2.1.7 contains a denial of service vulnerability that allows authenticated media authors to exhaust memory by uploading compressed oversized raster images. Attackers can reference a Twig or Markdown transform so GD or Imagick decodes the full source without dimension checks, letting anonymous requests repeatedly cause page unavailability.
Affected products
- getgrav grav: before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: getgrav grav 2.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-h253-r5hw-95r5
- https://www.vulncheck.com/advisories/grav-before-2.1.7-memory-exhaustion-via-oversized-image-transforms
Get alerted when CVE-2026-109324 or the next vulnerability affects your stack