What’s Vulnerable › Vulnerabilities
CVE-2026-109327: Admidio 4.0.12 through 4.3.17 and 5.0.0 before 5.0.15 Reflected XSS via system/redirect.php
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-79
Description
Admidio 4.0.12 through 4.3.17 and 5.0.0 before 5.0.15 contains a reflected cross-site scripting vulnerability in system/redirect.php that allows unauthenticated attackers to inject JavaScript via the url GET parameter, due to an incomplete fix for CVE-2021-43810. Attackers can craft a javascript: URL containing a decoy http:// segment that passes validation and executes script in the Admidio origin when victims click the redirect link.
Affected products
- admidio: from 4.0.12 through 4.3.17; from 5.0.0 before 5.0.15 — fixed in 5.0.15
How to fix
Upgrade to a fixed version: admidio 5.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/Admidio/admidio/security/advisories/GHSA-vxfg-x6vc-7w3w
- https://www.vulncheck.com/advisories/admidio-4.0.12-through-4.3.17-and-5.0.0-before-5.0.15-reflected-xss-via-system-redirect-php
- https://github.com/Admidio/admidio/security/advisories/GHSA-vxfg-x6vc-7w3w
Get alerted when CVE-2026-109327 or the next vulnerability affects your stack