What’s Vulnerable › Vulnerabilities
CVE-2026-109331: Network-AI 5.14.0 before 5.15.2 Deny Pattern Bypass via ClaudeHookBridge extractFullTarget
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-26
- Weakness: CWE-436
Description
Network-AI from 5.14.0 before 5.15.2 contains a security control bypass vulnerability in the ClaudeHookBridge PreToolUse hook, which matches deny patterns only against the first present candidate field. A prompt-injected agent can place dangerous payloads in fields like Write content or an MCP script parameter beside a benign file_path or command, evading denyPatterns to write web shells or execute scripts.
Affected products
- Jovancoding Network-AI: from 5.14.0 before 5.15.2 — fixed in 5.15.2
How to fix
Upgrade to a fixed version: Jovancoding Network-AI 5.15.2. Check the vendor advisory for mitigations.
References
- https://github.com/Jovancoding/Network-AI/security/advisories/GHSA-9p2w-prp8-5722
- https://www.vulncheck.com/advisories/network-ai-5.14.0-before-5.15.2-deny-pattern-bypass-via-claudehookbridge-extractfulltarget
Get alerted when CVE-2026-109331 or the next vulnerability affects your stack