What’s Vulnerable › Vulnerabilities
CVE-2026-109337: SurrealDB before 3.3.0 Field Permission Bypass via LIVE SELECT WHERE Clause
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-203
Description
SurrealDB before 3.3.0 contains an authorization bypass vulnerability that allows record users to infer field values hidden by field-level SELECT permissions using LIVE SELECT WHERE predicates over $before or $after. Attackers can craft repeated predicates and observe whether notifications are delivered on CREATE, UPDATE, or DELETE to confirm or narrow restricted field values.
Affected products
- surrealdb: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: surrealdb 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-jm88-9wvx-6h4q
- https://www.vulncheck.com/advisories/surrealdb-before-3.3.0-field-permission-bypass-via-live-select-where-clause
Get alerted when CVE-2026-109337 or the next vulnerability affects your stack