What’s Vulnerable › Vulnerabilities
CVE-2026-109343: SurrealDB before 3.3.0 Cross-Tenant Access via USE Statement
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-639
Description
SurrealDB before 3.3.0 allows cross-tenant access because the SurrealQL USE statement switches a session to any namespace/database without checking that the caller's authenticated level covers it. Authenticated namespace, database, or record users can switch to another tenant and read, create, update, or delete rows in tables whose PERMISSIONS allow it, such as PERMISSIONS FULL.
Affected products
- surrealdb: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: surrealdb 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-2v9j-645m-pcrq
- https://www.vulncheck.com/advisories/surrealdb-before-3.3.0-cross-tenant-access-via-use-statement
Get alerted when CVE-2026-109343 or the next vulnerability affects your stack