What’s Vulnerable › Vulnerabilities
CVE-2026-109346: better-auth 1.3.8-beta.3 before 1.7.0-rc.3 Device Authorization Phishing via /device
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-26
- Weakness: CWE-451
Description
better-auth from 1.3.8-beta.3 before 1.7.0-rc.3 contains a UI misrepresentation vulnerability in the deviceAuthorization plugin because GET /device omits the requesting client_id and scope. Attackers can start a device request via /device/code, trick signed-in users into approving the code, then redeem it at /device/token for a live session token.
Affected products
- Npm Better-Auth: from 1.3.8-beta.3 before 1.7.0-rc.3 — fixed in 1.7.0-rc.3
- better-auth: from 1.3.8-beta.3 before 1.7.0-rc.3 — fixed in 1.7.0-rc.3
How to fix
Upgrade to a fixed version: Npm Better-Auth 1.7.0-rc.3; better-auth 1.7.0-rc.3. Check the vendor advisory for mitigations.
References
- https://github.com/better-auth/better-auth/security/advisories/GHSA-q84f-53jg-9ppm
- https://www.vulncheck.com/advisories/better-auth-1.3.8-beta.3-before-1.7.0-rc.3-device-authorization-phishing-via-device
Get alerted when CVE-2026-109346 or the next vulnerability affects your stack