What’s Vulnerable › Vulnerabilities
CVE-2026-109353: LibreNMS before 26.9.0 SQL Injection via notification_id in notifications.inc.php
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-89
Description
LibreNMS before 26.9.0 contains an SQL injection vulnerability that allows unprivileged users to inject SQL by supplying an array-valued notification_id parameter to notifications.inc.php. Attackers can perform cross-table reads of users.password hashes, with results persisted in notifications_attribs and readable through the interface.
Affected products
- librenms: before 26.9.0 — fixed in 26.9.0
How to fix
Upgrade to a fixed version: librenms 26.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-2pw7-8mmj-gcw5
- https://www.vulncheck.com/advisories/librenms-before-26.9.0-sql-injection-via-notification-id-in-notifications-inc-php
- https://github.com/librenms/librenms/security/advisories/GHSA-2pw7-8mmj-gcw5
Get alerted when CVE-2026-109353 or the next vulnerability affects your stack