What’s Vulnerable › Vulnerabilities
CVE-2026-109354: LibreNMS before 26.9.0 Path Traversal via NFSen channel Parameter
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-22
Description
LibreNMS before 26.9.0 contains a path traversal vulnerability in nfsen_channel_common.inc.php that allows authenticated users to read unauthorized RRD data by injecting ../ sequences into the channel parameter. Attackers with access to one NFSen-enabled device can request graph.php with a traversed channel value to view traffic and NetFlow graphs of devices outside their authorized scope.
Affected products
- librenms: before 26.9.0 — fixed in 26.9.0
How to fix
Upgrade to a fixed version: librenms 26.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-j3qf-h24w-9f42
- https://www.vulncheck.com/advisories/librenms-before-26.9.0-path-traversal-via-nfsen-channel-parameter
Get alerted when CVE-2026-109354 or the next vulnerability affects your stack