What’s Vulnerable › Vulnerabilities
CVE-2026-109358: Edgeless Systems Contrast 1.8.0 before 1.24.1 World-Writable Containerd Config Privilege Escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-732
Description
Edgeless Systems Contrast 1.8.0 before 1.24.1 contains an incorrect permissions vulnerability where the node installer writes the containerd config world-writable (0666). Local unprivileged users on the node can modify the containerd config, for example overwriting the runc location, to escalate privileges.
Affected products
- edgelesssys contrast: from 1.8.0 before 1.24.1 — fixed in 1.24.1
How to fix
Upgrade to a fixed version: edgelesssys contrast 1.24.1. Check the vendor advisory for mitigations.
References
- https://github.com/edgelesssys/contrast/security/advisories/GHSA-376m-h37w-4rvq
- https://www.vulncheck.com/advisories/edgeless-systems-contrast-1.8.0-before-1.24.1-world-writable-containerd-config-privilege-escalation
Get alerted when CVE-2026-109358 or the next vulnerability affects your stack