What’s Vulnerable › Vulnerabilities
CVE-2026-109390
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-130
Description
AnyDesk before 8.0.3 allows unauthenticated remote attackers to execute arbitrary code via a heap-based buffer overflow, as demonstrated on Linux for command execution as root without the victim approving desktop control. In the stream packet handler for mode 5 in the session protocol, a payload length value is not validated.
Affected products
- AnyDesk: from 8.0.0 before 8.0.3 — fixed in 8.0.3
How to fix
Upgrade to a fixed version: AnyDesk 8.0.3. Check the vendor advisory for mitigations.
References
- https://anydesk.com/en/changelog/linux
- https://github.com/v12-security/pocs/tree/main/anydesk
- https://github.com/v12-security/pocs/tree/main/anydesk
Get alerted when CVE-2026-109390 or the next vulnerability affects your stack