What’s Vulnerable › Vulnerabilities
CVE-2026-109398: Gumlet php-image-resize before 3.0.1 Denial of Service via Decompression Bombs
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-409
Description
Gumlet php-image-resize before 3.0.1 contains a denial of service vulnerability because the ImageResize constructor in lib/ImageResize.php passes images to GD imagecreatefrom* functions without pixel limits. Remote attackers can upload small, highly compressed images that decode to large bitmaps, exhausting PHP memory and terminating the worker process.
Affected products
- gumlet php-image-resize: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: gumlet php-image-resize 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/gumlet/php-image-resize/blob/3.0.0/lib/ImageResize.php#L122-L163
- https://github.com/gumlet/php-image-resize/commit/10c1f386e672536d82be0f39b236a80d87767a50
- https://github.com/gumlet/php-image-resize/commit/cd01c9e8aa2382211d760c825799c8102987a8c2
- https://github.com/gumlet/php-image-resize/releases/tag/3.0.1
- https://github.com/gumlet/php-image-resize/security/advisories/GHSA-3g9v-hjrx-mg5h
- https://www.vulncheck.com/advisories/gumlet-php-image-resize-before-3.0.1-denial-of-service-via-decompression-bombs
- https://github.com/gumlet/php-image-resize/security/advisories/GHSA-3g9v-hjrx-mg5h
Get alerted when CVE-2026-109398 or the next vulnerability affects your stack