What’s Vulnerable › Vulnerabilities
CVE-2026-1094: Improper Validation of Unsafe Equivalence in Input in GitLab
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-11 · updated 2026-06-17
- Weakness: CWE-1289
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.8 before 18.8.4 that could have allowed an authenticated developer to hide specially crafted file changes from the WebUI.
Affected products
- GitLab: from 18.8.0 before 18.8.4 — fixed in 18.8.4
How to fix
Upgrade to a fixed version: GitLab 18.8.4. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/02/10/patch-release-gitlab-18-8-4-released/
- https://gitlab.com/gitlab-org/gitlab/-/issues/586483
- https://hackerone.com/reports/3502519
Get alerted when CVE-2026-1094 or the next vulnerability affects your stack