What’s Vulnerable › Vulnerabilities
CVE-2026-109414: Vitepos <= 3.6.1 - Authenticated (Vendor+) SQL Injection via 'src_by[].val' Parameter via 'bt' Operator
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-16
- Weakness: CWE-89
Description
The Vitepos – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to blind SQL Injection via the 'src_by[].val.start / src_by[].val.end (operator 'bt')' parameter in all versions up to, and including, 3.6.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with vendor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is an incomplete fix for a previously patched SQL injection (version 3.6.0), which addressed only the gt/lt/le/ge operators while leaving the 'bt' (BETWEEN) operator branch unpatched.
Affected products
- appsbd Vitepos – Point of Sale (POS) for WooCommerce: through 3.6.1
References
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vendor/appsbd-wp/appsbd-lite/appsbd_lite/v6/core/class-basemodel.php#L2925
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-outlet-api.php#L66
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-purchase-api.php#L71
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-vendor-api.php#L74
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/libs/class-api-base.php#L467
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3732582%40vitepos-lite&new=3732582%40vitepos-lite
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bb6c82b0-d9c7-4777-829d-885f24da4f36?source=cve
Get alerted when CVE-2026-109414 or the next vulnerability affects your stack