What’s Vulnerable › Vulnerabilities
CVE-2026-109561: goose from 1.28.0 before 1.44.0 Manual Approval Bypass via Read-Only Tool Annotations
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-26
- Weakness: CWE-863
Description
goose from 1.28.0 before 1.44.0 contains an authorization bypass vulnerability that allows tools to run without user approval in Manual Approval mode because persisted read-only annotations are never cleared by update_goose_mode. After a session uses Smart Approval mode, prompt-injected calls to tools annotated readOnlyHint: true execute without prompting, bypassing the user's selected approval mode in PermissionInspector::inspect.
Affected products
- aaif-goose goose: from 1.28.0 before 1.44.0 — fixed in 1.44.0
How to fix
Upgrade to a fixed version: aaif-goose goose 1.44.0. Check the vendor advisory for mitigations.
References
- https://github.com/aaif-goose/goose
- https://github.com/aaif-goose/goose/blob/v1.43.0/crates/goose/src/permission/permission_inspector.rs#L159
- https://github.com/aaif-goose/goose/commit/b0f4e2a0f1a5507aa0a0fbe73d0b5c77a3e86845
- https://github.com/aaif-goose/goose/pull/10528
- https://github.com/aaif-goose/goose/releases/tag/v1.44.0
- https://www.vulncheck.com/advisories/goose-from-1.28.0-before-1.44.0-manual-approval-bypass-via-read-only-tool-annotations
Get alerted when CVE-2026-109561 or the next vulnerability affects your stack