What’s Vulnerable › Vulnerabilities
CVE-2026-109565: Rapyd Admin 9.4.0 before 9.20.0 Stored XSS via select-list Component
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-79
Description
Rapyd Admin from 9.4.0 before 9.20.0 contains a stored cross-site scripting vulnerability that allows unauthenticated attackers to inject scripts through self-registered display names. Attackers can register with an HTML or JavaScript name rendered unescaped in the Activity log Author filter, executing in an administrator's session.
Affected products
- zofe rapyd-admin: from 9.4.0 before 9.20.0 — fixed in 9.20.0
How to fix
Upgrade to a fixed version: zofe rapyd-admin 9.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/zofe/rapyd-admin
- https://github.com/zofe/rapyd-admin/blob/v9.19.0/resources/views/components/select-list.blade.php#L108
- https://github.com/zofe/rapyd-admin/commit/acd6ee85f9e5ccec67199673b039c605d161406a
- https://github.com/zofe/rapyd-admin/releases/tag/v9.20.0
- https://www.vulncheck.com/advisories/rapyd-admin-9.4.0-before-9.20.0-stored-xss-via-select-list-component
Get alerted when CVE-2026-109565 or the next vulnerability affects your stack