What’s Vulnerable › Vulnerabilities
CVE-2026-109567: Rapyd Admin from 9.0.0 before 9.20.0 Privilege Escalation via UsersEdit Component
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-269
Description
Rapyd Admin from 9.0.0 before 9.20.0 contains an improper privilege management vulnerability in the UsersEdit Livewire component that allows users with the edit users permission to assign themselves the admin role. Attackers holding roles such as the shipped operator role can submit the admin role ID for their own account, lifting tenant scoping, bypassing per-record authorization, and enabling impersonation.
Affected products
- zofe rapyd-admin: from 9.0.0 before 9.20.0 — fixed in 9.20.0
How to fix
Upgrade to a fixed version: zofe rapyd-admin 9.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/zofe/rapyd-admin
- https://github.com/zofe/rapyd-admin/blob/v9.19.0/app/Modules/Auth/Livewire/UsersEdit.php#L119-L121
- https://github.com/zofe/rapyd-admin/commit/acd6ee85f9e5ccec67199673b039c605d161406a
- https://github.com/zofe/rapyd-admin/releases/tag/v9.20.0
- https://www.vulncheck.com/advisories/rapyd-admin-from-9.0.0-before-9.20.0-privilege-escalation-via-usersedit-component
Get alerted when CVE-2026-109567 or the next vulnerability affects your stack