What’s Vulnerable › Vulnerabilities
CVE-2026-109572: Open WebUI 0.8.6 before 0.11.4 Privilege Escalation via Terminal Proxy
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-862
Description
Open WebUI from 0.8.6 before 0.11.4 contains a privilege escalation vulnerability in the terminal proxy that allows authenticated users to reach the Terminals administrator API with the shared key attached. Attackers can send requests through /api/v1/terminals/{server_id}/{path} to list or stop other users' terminals and modify terminal policies, injecting environment variables into other users' terminals.
Affected products
- open-webui: from 0.8.6 before 0.11.4 — fixed in 0.11.4
How to fix
Upgrade to a fixed version: open-webui 0.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/open-webui/open-webui/commit/51bb8cb142f72503e861eeee25ae4dc73c26c36b
- https://github.com/open-webui/open-webui/security/advisories/GHSA-q46m-r89w-j74p
- https://www.vulncheck.com/advisories/open-webui-0.8.6-before-0.11.4-privilege-escalation-via-terminal-proxy
Get alerted when CVE-2026-109572 or the next vulnerability affects your stack