What’s Vulnerable › Vulnerabilities
CVE-2026-109598: Frappe before 16.33.0 Broken Authorization via send_sms Endpoint
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-862
Description
Frappe Framework before 15.120.0 and 16.x before 16.33.0 contains a missing authorization vulnerability in the whitelisted send_sms API endpoint, which does not verify that the caller is permitted to send SMS messages. Users lacking the required permissions can invoke send_sms to send arbitrary SMS messages that impersonate the Company.
Affected products
- frappe: before 15.120.0; from 16.0.0-beta.1 before 16.33.0 — fixed in 15.120.0, 16.33.0
How to fix
Upgrade to a fixed version: frappe 15.120.0, 16.33.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-wrh5-p77r-jpvq
- https://www.vulncheck.com/advisories/frappe-before-16.33.0-broken-authorization-via-send-sms-endpoint
Get alerted when CVE-2026-109598 or the next vulnerability affects your stack