What’s Vulnerable › Vulnerabilities
CVE-2026-109603: Frappe Framework before 16.17.0 Authenticated SSRF and LFI via pdfkit
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-918
Description
Frappe Framework 15.x before 15.107.3 and 16.x before 16.17.0 relies on a vulnerable pdfkit library (CVE-2025-26240) for PDF generation, enabling server-side request forgery and local file inclusion. Authenticated attackers can supply crafted content to PDF rendering to make the server fetch internal resources or embed local server files in generated PDFs.
Affected products
- frappe: before 15.107.3; from 16.0.0-beta.1 before 16.17.0 — fixed in 15.107.3, 16.17.0
How to fix
Upgrade to a fixed version: frappe 15.107.3, 16.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-pj59-9hv9-rmrv
- https://www.vulncheck.com/advisories/frappe-framework-before-16.17.0-authenticated-ssrf-and-lfi-via-pdfkit
Get alerted when CVE-2026-109603 or the next vulnerability affects your stack