What’s Vulnerable › Vulnerabilities
CVE-2026-109608: Frappe ERPNext before 15.121.0 SQL Injection via Unvalidated Endpoint Input
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-89
Description
Frappe ERPNext before 15.121.0 and 16.x before 16.34.0 contains an SQL injection vulnerability in several endpoints that lack input validation. Any authenticated user, including one with no assigned roles, can send specially crafted requests to read other users' sensitive information and escalate to a privileged account.
Affected products
- frappe erpnext: before 15.121.0; from 16.0.0-beta.1 before 16.34.0 — fixed in 15.121.0, 16.34.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.121.0, 16.34.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-v38v-9h2p-hr8v
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.121.0-sql-injection-via-unvalidated-endpoint-input
Get alerted when CVE-2026-109608 or the next vulnerability affects your stack