What’s Vulnerable › Vulnerabilities
CVE-2026-109612: Frappe ERPNext before 15.120.0 Stored XSS via Report View
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-18
- Weakness: CWE-79
Description
Frappe ERPNext before 15.120.0 and 16.x before 16.33.0 contains a stored cross-site scripting vulnerability in a report view that interpolates stored record names into markup without escaping. Authenticated users able to create records can store crafted record names that execute script in the session of any user who later opens the report.
Affected products
- frappe erpnext: before 15.120.0; from 16.0.0-beta.1 before 16.33.0 — fixed in 15.120.0, 16.33.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.120.0, 16.33.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-f99r-gp2w-xghj
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.120.0-stored-xss-via-report-view
Get alerted when CVE-2026-109612 or the next vulnerability affects your stack