What’s Vulnerable › Vulnerabilities
CVE-2026-109633: Frappe ERPNext before 15.119.1 Stored XSS via Public Booking Page
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-79
Description
Frappe ERPNext before 15.119.1 and 16.x before 16.32.0 contains a stored cross-site scripting vulnerability because content submitted through a public-facing booking page is stored without neutralization. Unauthenticated attackers can submit crafted content that is rendered as raw HTML in a privileged user's session, executing script to act as that user and take over the account.
Affected products
- frappe erpnext: before 15.119.1; from 16.0.0-beta.1 before 16.32.0 — fixed in 15.119.1, 16.32.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.119.1, 16.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-rv4r-c8v3-3hrc
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.119.1-stored-xss-via-public-booking-page
Get alerted when CVE-2026-109633 or the next vulnerability affects your stack