What’s Vulnerable › Vulnerabilities
CVE-2026-109640: Frappe ERPNext before 16.22.0 Missing Authorization Allows Unauthorized Record Modification
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-18
- Weakness: CWE-862
Description
Frappe ERPNext before 16.22.0 contains a missing authorization vulnerability that allows authenticated users to modify records by invoking endpoints lacking proper authorization checks. Attackers can call these endpoints to perform operations on records beyond their permitted role, resulting in unauthorized modification of data.
Affected products
- frappe erpnext: before 16.22.0 — fixed in 16.22.0
How to fix
Upgrade to a fixed version: frappe erpnext 16.22.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-c496-q7g2-62vv
- https://www.vulncheck.com/advisories/frappe-erpnext-before-16.22.0-missing-authorization-allows-unauthorized-record-modification
Get alerted when CVE-2026-109640 or the next vulnerability affects your stack