What’s Vulnerable › Vulnerabilities
CVE-2026-109642: Frappe ERPNext before 15.110.0 Missing Authorization in Certain Endpoints
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-14
- Weakness: CWE-862
Description
Frappe ERPNext before 15.110.0 and 16.x before 16.21.0 contains a missing authorization vulnerability in which certain endpoints fail to enforce proper authorization checks. Authenticated users can query these endpoints to read data beyond what their assigned role permits.
Affected products
- frappe erpnext: before 15.110.0; from 16.0.0-beta.1 before 16.21.0 — fixed in 15.110.0, 16.21.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.110.0, 16.21.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-m45g-7cw5-pvr4
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.110.0-missing-authorization-in-certain-endpoints
Get alerted when CVE-2026-109642 or the next vulnerability affects your stack