What’s Vulnerable › Vulnerabilities
CVE-2026-109649: Frappe ERPNext before 15.102.0 SQL Injection via Unvalidated Endpoint Requests
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-89
Description
Frappe ERPNext before 15.102.0 and 16.x before 16.11.0 contains an SQL injection vulnerability in some endpoints due to missing input validation, allowing manipulation of database queries. Authenticated attackers can send specially crafted requests to the affected endpoints to extract sensitive information from the database.
Affected products
- frappe erpnext: before 15.102.0; from 16.0.0-beta.1 before 16.11.0 — fixed in 15.102.0, 16.11.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.102.0, 16.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-9ph8-h5v4-97j6
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.102.0-sql-injection-via-unvalidated-endpoint-requests-2
Get alerted when CVE-2026-109649 or the next vulnerability affects your stack