What’s Vulnerable › Vulnerabilities
CVE-2026-109651: Frappe ERPNext before 15.112.0 Server-Side Request Forgery via Configuration Field
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-918
Description
Frappe ERPNext before 15.112.0 and 16.x before 16.23.0 contains a server-side request forgery vulnerability caused by a configuration field, writable by common operational roles, that accepts an arbitrary outbound request destination without validation. Authenticated attackers can set the field to hosts of their choosing, making the server issue requests to addresses reachable only from inside the deployment's network.
Affected products
- frappe erpnext: before 15.112.0; from 16.0.0-beta.1 before 16.23.0 — fixed in 15.112.0, 16.23.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.112.0, 16.23.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-6qcc-cw7f-328g
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.112.0-server-side-request-forgery-via-configuration-field
Get alerted when CVE-2026-109651 or the next vulnerability affects your stack