What’s Vulnerable › Vulnerabilities
CVE-2026-109652: Frappe ERPNext before 15.119.1 Server-Side Template Injection via Message Fields
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-14
- Weakness: CWE-1336
Description
Frappe ERPNext before 15.119.1 and 16.x before 16.32.0 contains a server-side template injection vulnerability because user-controlled message fields are not validated before template rendering, allowing expressions to run in an unrestricted context. Authenticated attackers holding a common operational role can inject template expressions to read and write arbitrary database data, delete documents, send outbound requests from the server, and send mail from the site.
Affected products
- frappe erpnext: before 15.119.1; from 16.0.0-beta.1 before 16.32.0 — fixed in 15.119.1, 16.32.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.119.1, 16.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-6w83-8777-v93q
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.119.1-server-side-template-injection-via-message-fields
Get alerted when CVE-2026-109652 or the next vulnerability affects your stack