What’s Vulnerable › Vulnerabilities
CVE-2026-109653: Frappe ERPNext before 15.119.0 Stored XSS Leading to Account Takeover
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-79
Description
Frappe ERPNext before 15.119.0 and 16.x before 16.31.0 contains a stored cross-site scripting vulnerability because record fields are rendered into an HTML attribute context without escaping. A low-privilege user can store a malicious payload in a record field that executes in the browser of any privileged user who opens the affected page, enabling account takeover.
Affected products
- frappe erpnext: before 15.119.0; from 16.0.0-beta.1 before 16.31.0 — fixed in 15.119.0, 16.31.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.119.0, 16.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-8pr6-r75h-h8xx
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.119.0-stored-xss-leading-to-account-takeover
Get alerted when CVE-2026-109653 or the next vulnerability affects your stack